Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

How I enable directory browsing in IIS7?

MS technet says this can be done in the IIS console:

  1. Open IIS Manager and navigate to the level you want to manage.

  2. In Features View, double-click Directory Browsing.

  3. In the Actions pane, click Enable if the Directory Browsing feature is disabled and you want to enable it. Or, click Disable if the Directory Browsing feature is enabled and you want to disable it.

However, my IIS console doesn't have the Directory Browsing option mentioned in Step 2.

How can this option be made available.

Note, this is for a static HTML site, so I don't have any web.config or ASPX files.

share|improve this question
up vote 5 down vote accepted

That's because 'Directory Browsing' is one of the Role services you have to specifically install. You do that from Server Manager -> Roles -> Web Services -> Add Role Services. Pick 'Directory Browsing' in the wizard. Then you should have the options specified in the KB article.

share|improve this answer

And for the command line nerds out there, to do this without the GUIs:

servermanagercmd -install Web-Dir-Browsing
appcmd set config (url) /section:directoryBrowse /enabled:true

where (url) is the name of your web site and optional path to virtual directory, like "Default Web Site/Pictures". You can list web sites by typing

appcmd list site
share|improve this answer

Instead of Features View... click on your site, look under "IIS" - where it has authentication, MIME Types, Compression etc.

There should be a Directory Browsing icon, it's where I located mine.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.