Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I'm setting up a Windows Server 2008 box, and everything is working great (database, remote login, etc.), but it doesn't respond to ping. Normally I might not care, but I'm setting up Nagios monitoring for it, too, and Nagios seems to want to know it can ping it.

My first thought was the firewall, but I even tried turning the firewall off entirely for a minute, and I still couldn't ping it.

What am I missing? Is there something I need to enable/disable to make ping work?

(Have pity ... I'm normally a Unix admin, not a Windows admin. :-)

share|improve this question

2 Answers 2

Ah, I'm an idiot. I'd tried turning the firewall off but only managed to do so for one profile. The public profile (duh) was indeed blocking ICMP ECHO.

Solved...

share|improve this answer
    
You didn't turn off the public profile firewall, did you? I'm pretty sure you would have just enabled ICMP Echo but your wording has me worried! –  William Jun 23 '10 at 4:50

Thanks..what I did to my Win Server 2008 R2 Ent.. was click to Administrative Tools then Windows Firewall and Advanced Security..go to Inbound Rules..navigate to File and Printer Sharing (Echo Request - ICMv4-in) as well as ICMv6in) and voila i can ping now..

Marlon V. Macua LGU-Trinidad, Bohol Sys Admin

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.