Server Fault is a question and answer site for system and network administrators. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have Zend Server installed on my Windows XP development machine, installed when I was naive and didn't know that Eclipse was going to become so suck so badly for PHP development.

I've made the upgrade to Netbeans, but for debugging they only support xDebug. To be fair I've never used "proper" debuggers before, but other folks have raved about them so I thought I'd give it a try.

I followed some directions on the Zend forum about how to install xDebug on Zend server, disabling Zend Debugger in the process.

The xDebug "custom installation instructions" wizard tells me that my PHP was compiled with an unsupported compiler (MS VC8), and won't let me download anything. I tried a couple of the other xDebug binaries, but they just refused to load. So I'm left without a debugger option. Does anyone know how I can change the compiler of the php version I have installed so I can use a debugger in Netbeans? or how else i can get xDebug to install on Zend Server?

share|improve this question

closed as off-topic by kce, Tim Brigham, Ward, Falcon Momot, Bryan Jul 25 '13 at 7:05

This question appears to be off-topic. The users who voted to close gave this specific reason:

  • "Questions about software development are off-topic here, but can be asked on Stack Overflow." – kce, Tim Brigham, Ward, Falcon Momot, Bryan
If this question can be reworded to fit the rules in the help center, please edit the question.

You can Use this instruction: here

share|improve this answer
Thanks - unfortunately I'm using php 5.3.1, so that's not much use, which is why I mentioned the link above. I'm going to try to upgrade Zend Server as there's a new version out - to see if it's been compiled with a more suitable compiler. I'll report back here when I have. – Hippyjim Oct 11 '10 at 10:15

Ok, since Zend Server's been updated (v5.0.3) - I had another try using the "tailored install" wizard - and it seems they're using a supported compiler now.

It all "just worked".

share|improve this answer

Not the answer you're looking for? Browse other questions tagged or ask your own question.