Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I tried to install RHEL 5.4 both 64 and 32 bits on VirtualBox 3.2.4-62467 in Ubuntu 9.1 with no success. It all goes fine but in the end gets stuck. Any success stories ? Hints ? Thanks

share|improve this question

4 Answers 4

up vote 1 down vote accepted

Quick glance here shows it should be working. Are you using the repo version or the downloaded .deb from Virtualbox? I've had better luck with the version directly from VBox.

share|improve this answer
    
Good point, I'll download it directly then (currently pointing to the repo). –  xain Jun 24 '10 at 13:19

I had the same problem with both 32/64 bit versions of RHEL 5.5 on VirtualBox 3.2.4 and 3.1.8. I'm using 64bit Ubuntu 9.10 as well. Both VirtualBox installs were done via the official VBox apt repository. After doing a lot of searching, my best guess is that this is related to a problem with virtual disks that are stored on ext4 partitions. Moving your virtual disks to an ext3 partition should work.

However, what I ended up doing is removing the SATA controller in the VirtualBox storage settings. SATA was the default on my system when I created the VM so I deleted the SATA controller and then added the virtual disk to the IDE Controller as the primary master. Simply moving the virtual disk to the IDE controller and not removing the SATA controller didn't work for some reason. Once I did this my 64 bit install was finally able to boot post install. I hope this helps.

share|improve this answer

If this situation is anything like OpenSolaris with AMD processors, then it may come down to possibly older AMD lines not be "accepted" by the OS. In some cases, the Windows version of the Virtualbox hypervisor may be more "forgiving" with the older AMD lines.

share|improve this answer

When you say “the end” does that mean it installs but then can't boot? Do you get any sort of errors during boot after the install? Specifically about the NMI watchdog?

When I was testing some CentOS5 VMs on VirtualBox, I ran into a similar issue. I Googled based on that error and I ending up adding something to the end of the grub boot command which made it work: nmi_watchdog=0

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.