Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

One of our Gateway 7400 servers has been beeping for days. The beep is audible, but very low and seems to be a random series of short high-low beeps that are sometimes slow and sometimes speedup significantly. It almost sounds like a key on the keyboard is stuck, but there is no real pattern that I can detect.

Something strange is this- when I remove the cover to examine the hardware, the beeping stops and does not start back until 1-10 minutes after replacing the cover.

One of the PSU's is bad and has been removed until it can be replaced. I thought this was the cause of the alarm, but now I am not so sure as the beeping continues.

The one SCSI drive in the array does not appear to be bad.

I really hate to ask this here, but the manual does not cover this AND I havent been able to find any info online. I am hoping there is a dinosaur somewhere with experience using 10-year-old Gateway 7400 servers.

Thanks in advance.

share|improve this question
1  
Is it beeping right after a cold (as in: fully cooled down) boot? Could be thermal alarm. Also, sometimes fans can do funny things. –  Joris Aug 15 '10 at 18:40
    
Have you tried leaving the case open for a while; sounds like it might be a thermal alarm as Joris said. –  Chris S Oct 7 '10 at 1:59
    
Actually I have been running it with the cover off for over a month and havent heard the alarm once. If you submit this as an answer, I will check it at the correct one. Thanks to everyone for advice. –  cop1152 Oct 7 '10 at 13:35

2 Answers 2

I had the same problem with one of mines : it can be a GROUNDING problem causing memory errors... The random beep you heard is probably the ECC feature alerting you from an unrecoverable memory error, like said in the manual. An amber LED show this on the front panel. For me, the solution is to isolate the motherboard from the chassis with plastic or paper eyelets (in France we call this 'oeillets'- to repair papersheets). Now, motherboard screws and spacers don't touch the grounding surface of the motherboard. Solved problem.

share|improve this answer

According to the Gateway 7400 Server System Manual (PDF), there's a power supply alarm speaker reset switch to the right of the power button. Try pressing that switch.

Otherwise, have you tried taking the cover off and activating the intruder switch so it thinks the cover is still in place? You may be better able to hear the sound and might even use a tube placed next to your ear and moved around to isolate the source.

share|improve this answer
    
I should have mentioned that I reset the PSU alarm switch and the intruder switch for the chassis has been disconnected for ages and has never beeped in the past. –  cop1152 Jun 24 '10 at 18:47
    
I wasn't expecting that the intruder alarm was beeping. My thought was that, had it been functional, you could press it with the cover off and be more able to hear what was beeping. Now I'm thinking it might be a temperature sensor. Also, are you sure it's beeping and not creaking/squeeking (with old age [ semi - ;-) ])? I'd still recommend the ad-hoc car-engine stethoscope method. –  Dennis Williamson Jun 24 '10 at 19:04

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.