Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I don't know much about email servers and I am having some problems.

I am trying to setup exim to forward emails to another port on the local host for testing purposes. Exim should basically connect to my test smtp server and send an email.

Python Test SMTP server: listens on port 9100, when an email is successfully sent, it prints it to the console. I have tested this by telnetting in and manually sending emails and it works fine

I want exim to relay all sent emails to this test server, which is on a different port on the same machine (localhost:9100).

The problem is, I keep getting the following error messages in my main log:

2010-06-24 22:29:17 1ORs6v-0002MP-Vv <= bill@bill-laptop U=bill P=local S=344 2010-06-24 22:29:18 1ORs6v-0002MP-Vv remote host address is the local host: somehwere.com 2010-06-24 22:29:18 1ORs6v-0002MP-Vv == bill@somehwer.com R=smarthost defer (-1): remote host address is the local host

Is there anyway for me to disable this check?

share|improve this question

2 Answers 2

Exim doesn't, by default, let you send mail back to yourself. You can change this behavior by using the self router option. Here's an example from my config in which I had to use self = send to get Exim to send "slow" mail to another instance on the same host:

stalemail:
  driver = manualroute
  condition = ${if > {$message_age}{900}{yes}{no}}
  self = send
  domains = ! +local_domains
  route_list = * mailhub-01.example.com::8025:mailhub-02.example.com::8025
  transport = remote_smtp
share|improve this answer
    
This filter (stalemail) seems to be about, well, stale mail. :) I was having this problem at a filter called dnslookup; I put it there, problem solved! –  Ekevoo May 5 '11 at 21:27

Does it work if you bind the test server to a different address in the loopback range, such as 127.255.0.1?

share|improve this answer
    
It worked for me when I told it to pass mail onto a 127.1.1.1 smarthost. –  sybreon Jun 14 '11 at 6:51

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.