Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

Newest apt package is 6.3.7 but has issues with png resizing.

share|improve this question
add comment

2 Answers

up vote 3 down vote accepted

This may belong on SuperUser, but assuming you mean "6.5.6 or later"...

Ensure that a sources entry for Squeeze (Testing) exists in /etc/apt/sources.list:

deb-src http://http.us.debian.org/debian squeeze main contrib non-free

Run apt-get update (as root)

Run apt-get build-dep imagemagick (as root, this installs the build-dependencies)

Change to a directory you'll be using for building.

For the next part you can be a regular user.

Run apt-get source imagemagick (should automatically pick up the version from Testing, currently 6.6.0)

This will download and unpack the latest source package. CD into the directory created that contains the unpacked source (imagemagick-6.6.0.4/ as of this writing).

Run fakeroot debian/rules binary and if all goes well, cd ..

In that directory will be a set of imagemagick debs that have only build-dependencies from Lenny (i.e. you just backported imagemagick for your environment).

As root again, run dpkg -i *.deb.

Enjoy your new packages, but remember to check for security releases periodically and rebuild as needed, as you are now outside of Debian's security release framework. You may want to consider subscribing to the debian-security-announce mailing list.

share|improve this answer
add comment

You can install selected packages from the testing repo.

The current testing is Debian Squeeze, which currently has ImageMagick 6.6.

share|improve this answer
    
Bad idea. Imagemagick from Testing is going to pull a huge number of dependencies, starting with libc6. If you're going to go that route, just go all the way and upgrade the entire system at once. –  Zed Jun 24 '10 at 21:14
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.