Server Fault is a question and answer site for system and network administrators. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have tried the following:

mailx -s "test"

which says bash no command found.

also have tried : Mail -s "test"

which says /usr/sbin/sendmail: No such file or directory

even though the file name is valid

share|improve this question
up vote 3 down vote accepted

For basic sending, just try echo "Body Text" | mutt -a <file> -s "test"

Now, as Sleske mentioned, you might need to modify /etc/mail/ to configure this differently. But if you're just wanting to send, and not receive, E-Mails locally, and you've already got an MX record for, I think you should be all set.

Also, given your 'command not found' issues, double check you have MTAs installed. use rpm -q sendmail or rpm -q mutt, and see if you find any packages.


share|improve this answer
(  cat body.txt 
   uuencode pic.jpg pic.jpg
) | mailx -s "subject" 

try this

share|improve this answer

You first need to set up a local mail server, and configure it to send mails (usually by passing them on to your ISP's relaying mail server).

See e.g.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.