Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

My hoster have assigned to my server a secondary IP adresse. For example, my primary IP adress is 174.10.10.1 and my secondary IP adress is 174.10.10.2.

My donmain name "example.com" is binded to the seconday IP adress (174.10.10.2). On my Windows server 2008, I have IIS 7 and the virtual SMTP service installed.

From this server, I send email notifications to the users of my hosted application. The problem is that the first HOP receives the emails from the primary IP adress (174.10.10.1) instead of the secondary IP adress (174.10.10.2), even if I connect to the virtual SMTP server through the secondary IP adress (174.10.10.2).

How can I make IIS Virtual SMTP server sending emails through the secondary IP adress rather than the primary adress.

Thanks

share|improve this question
add comment

1 Answer

up vote 0 down vote accepted

Not having worked with IIS7 much I don't know how to set it using the IIS7 manager but if you install the IIS6 manager you can easily access the properties of the SMTP service and change the bindings so that it only operates on the second ip address.

share|improve this answer
    
In IIS 7 you can too, my STMP is configured to use the secondary IP adress and not "All unassigned". Still, the header of the email sent by my server says that the email was received from the primary IP adress. –  Sebastien Jun 25 '10 at 3:43
    
Out of curiosity, did you stop and restart the SMTP service, or reboot the server after setting it to operate on the secondary ip address? –  joeqwerty Jun 25 '10 at 9:04
    
Yes I have restarted the SMTP service but I did not restart the whole server. I think that restarting the service shall be enough. I suspect that it is a routing problem more than a IIS Virtual SMTP configuration issue –  Sebastien Jun 25 '10 at 12:28
    
It just occured to me what's happening. I had been thinking about this from the perspective of the server's internal ip address, which is probably not the ip address you're getting from the hoster, right? If so, then you need to change the NAT on your firewall\router to use the second ip address from the hoster instead of the first. –  joeqwerty Jun 25 '10 at 13:20
    
Both IP adresses were assigned by my hoster. Both IP adresses are accessible from the Internet. Is it more a routing problem than a NAT issue ? –  Sebastien Jun 25 '10 at 17:02
show 3 more comments

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.