Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I installed pure-ftpd on Ubuntu 8.04 using

aptitude install pure-ftpd

What's the step to add users?

I'm new to pure-ftpd and PAM authentication. but I followed pure-ftpd documentation to do pure-pw useradd then restarted pure-ftpd but no dice.

It still says "authentication failed" when trying to connect with ftp client.

I verified that there is a /etc/pure-ftpd/pure-ftpd.passwd entry for the user that was added.

So what's the missing piece of the puzzle?

Wayne

share|improve this question
add comment

6 Answers

Nevermind, ftp isn't necessary. Just remembered ssh can be used to transfer files via scp. That is working. There's more than one way to skin a cat.

EDIT: This is the best way to solve the situation of installing or setting up a cloud computer instance because they always give you ssh access. Since scp runs on stop of ssh to transfer files, it means there's nothing to install or configure to transfer files.

Now if you need to do regular file updates then a different tool like maybe rsync or such would be better.

Sincerely, Wayne

share|improve this answer
    
Wayne - if this is how you resolved the problem, then please mark your answer as "Accepted" so that people will now that the question is closed. –  Guss Jun 15 '11 at 12:31
add comment

I've just had a similar problem. I've added user using pure-pw useradd and get 530 Login authentication failed.

The solution was a symlink added to /etc/pure-ftpd/auth directory pointing to /etc/pure-ftpd/conf/PureDB (there is a path to file that keeps ftp users) that shows in alphabetical order before other files in auth, e.g.

cd cd /etc/pure-ftpd/auth/
ln -s ../conf/PureDB 50PureDB

then ls returns:

50PureDB -> ../conf/PureDB
65unix -> ../conf/UnixAuthentication
70pam -> ../conf/PAMAuthentication
share|improve this answer
add comment

Did you run "pure-pw mkdb" after adding users?

share|improve this answer
    
No, but I just tried it. Same thing when I try to ftp localhost. The entry is still in the pureftp.passwd file. Is there any way to just make it user the linux /etc/passwd for authentication? I am the only user of the cloud instance so I don't need ftp after this update, I will disable it. It's irksome to get stuck on such a simple issue as ftping a file. –  Wayne Jun 25 '10 at 8:37
    
Did you reload the deamon also? Anyway read my other answer. –  lg. Jun 25 '10 at 10:10
add comment

Why you don't user sfpt (ssh-ftp)? With SFPT you login by nuormal user credential.

A simple SFTP client is FileZilla.

share|improve this answer
add comment

Pure FTPd is set by default in Ubuntu to authenticate using PAM. This means that you'd need to add users to the system's user database using the command useradd.

share|improve this answer
add comment

I recently had an issue which was solved here:

http://download.pureftpd.org/pure-ftpd/doc/FAQ

Not enough questions link to the answers in the FAQ.

To log in, the shell assigned to your users must be listed in the /etc/shells file

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.