Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I'm using KVM and libvirt and experience small network freezes on the host and the guests every 2-3 minutes or so. The freezes last 1-2 seconds. The used OS is Ubuntu 10 LTS server edition.

I'm using a standard bridge setup with the host additionally serving as a router for the guests (because the data center always routes the guest IPs to the host). This all works fine except for the occasional network freezes every few minutes. A mtr trace from external machines reports a packet loss of around 1-2% (for the host and the guests).

I found out that when I disable ip forwarding on the host (/proc/sys/net/ipv4/ip_forward), the freezes do not occur anymore (but the guests then obviously have no network connectivity), so I guess it's a software related problem rather than a hardware issue.

I've tried switching to alternative network drivers in the guests (from virtio to e1000/rtl), disabling our iptables packet filtering, playing around with various network options (turning off/on icmp redirects, among others) but this hasn't changed anything.

Any thoughts and ideas on this are much appreciated.

Thanks, Tobias

share|improve this question
add comment

2 Answers

Yes, I solved it by changing the bridge setup. Previously, I added the bridge directly to eth0 with the external IP address. I changed this to an internal bridge with the IP 10.0.0.1 and now route the public VM IPs through this bridge.

share|improve this answer
add comment

what are the first 2 characters of your MAC address? There is a known issue with brctl, where the MACs start off too high (e.g. new HP NICs start with D8:...)

share|improve this answer
    
The MAC addresses start with 40 for the host and 50 or lower for the guests. I even made sure to end them with an even number because I read there can be problems with uneven MAC addresses as well. –  Tobias G. Jun 25 '10 at 17:13
    
when you start all the guests, run ifconfig -a, and make sure the bridge the guests are attached to has the mac of a physical NIC and not from one ot the tap devices the guests use –  dyasny Jun 26 '10 at 8:05
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.