Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

Windows Server 2008 SP2 assigned a drive letter to the 100MB "System Reserved" partition during install. It's not supposed to do that (should leave it with an unassigned letter) and it's also bad because it is now visible as a drive like any other on the system. Can't get rid of the drive letter in disk mgmt since it's marked as a "system" partition.

I don't mind having the partition there but I really don't like having a letter assigned to it. What to do?

share|improve this question
add comment

4 Answers

up vote 0 down vote accepted

Here is what seems to be your problem. As you posted:

Microsoft DiskPart version 6.0.6002  
Copyright (C) 1999-2007 Microsoft Corporation.  
On computer: ADAPP02  

DISKPART> list vol  

Volume      Ltr  Label        Fs     Type        Size     Status     Info  
----------  ---  -----------  -----  ----------  -------  ---------  --------  
Volume 0     F                       DVD-ROM         0 B  No Media  
Volume 1     D   System Rese  NTFS   Partition    100 MB  Healthy    System  
Volume 2     C                NTFS   Partition    136 GB  Healthy    Boot  
Volume 3     E   Apps         NTFS   Partition    272 GB  Healthy    Pagefile  

If I'm reading this right, you've somehow managed to get the flags swapped between the System Reserved and the actual System partition. Windows won't let you change the drive letter of the System Partition, which in this case is the wrong partition. There isn't a way to change this short of hacking the partition table directly. This was set on install.

This is actually a dangerous config, since it's probably possible to change the drive letter of the drive that has the \Windows directory on it. That's supposed to be the drive flagged System, but that patently isn't the case here. Fixing this will require reinstalling your Server 2008. Or if that's not possible, you'll just have to live with the fact that %SystemRoot% is not C:\Windows.

No I don't know how it happened. It looks like a bug to me. If you have the option, calling Microsoft about it would be a good idea.

share|improve this answer
    
Thanks. That appears to be the issue. –  Aaron Jun 27 '10 at 16:07
add comment
  1. run diskpart.
  2. In that program type in list vol; not the volume number for the volume with the letter you want to get rid of (it'll probably be 0 or 1).
  3. type in sel vol # where # is the number you noted.
  4. type in remove letter=[letter] where [letter] is the drive letter of the reserved volume.
  5. use exit to exit the program

So a typical sequence might be:

diskpart
list vol
sel vol 1
remove letter=d
exit
share|improve this answer
add comment

This worked for me:

Run Disk Management Right Click on the System Reserved. Change Drive Letter and Paths Remove the letter and then restart.

share|improve this answer
add comment

Sorry, doesn't work. Gives me essentially the same error as in disk management:

Microsoft DiskPart version 6.0.6002  
Copyright (C) 1999-2007 Microsoft Corporation.  
On computer: ADAPP02  

DISKPART> list vol  

  Volume      Ltr  Label        Fs     Type        Size     Status     Info  
  ----------  ---  -----------  -----  ----------  -------  ---------  --------  
  Volume 0     F                       DVD-ROM         0 B  No Media  
  Volume 1     D   System Rese  NTFS   Partition    100 MB  Healthy    System  
  Volume 2     C                NTFS   Partition    136 GB  Healthy    Boot  
  Volume 3     E   Apps         NTFS   Partition    272 GB  Healthy    Pagefile  

DISKPART> sel vol 1  

Volume 1 is the selected volume.  

DISKPART> remove letter=d  

The selected volume is necessary to the operation of your computer.
You may not remove the drive letter from this volume.

DISKPART>  

Any thoughts?

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.