Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

Some of my mssql instances shut down after a while. After enabled logging I was able to get a error message why the services are down:

2010-06-23 15:49:53.34 Server      Server resumed execution after being idle 33570 seconds: user activity awakened the server. This is an informational message only. No user action is required.
2010-06-24 01:04:48.84 spid1s      Server resumed execution after being idle 32039 seconds. Reason: timer event.
2010-06-24 03:14:42.14 Server      SQL Server is terminating because of a system shutdown. This is an informational message only. No user action is required.
2010-06-24 03:15:56.35 spid7s      Server resumed execution after being idle 6949 seconds: user activity awakened the server. This is an informational message only. No user action is required.
2010-06-24 03:15:59.01 spid7s      Fehler: 17054, Schweregrad: 16, Status: 1.
2010-06-24 03:15:59.01 spid7s      The current event was not reported to the Windows Events log. Operating system error = (null). You may need to clear the Windows Events log if it is full.

I can't seem to google the meaning of error 17054? What does it mean?

How can I prevent the instance services to shutdown? The problem is, that the services do not start up automatically after such error, altough the startup type of the services are set to automatically.
I could program another service that watches the instance services and simplies starts them in case they are down. But I'd rather fix my problem with the MSSQL Server

share|improve this question

2 Answers 2

Sounds like the server is rebooting, perhaps because of auto-updates? The error 17054 is shown because SQL Server tried to write an event to the Windows Event Log, but it failed, probably related to the reboot.

share|improve this answer
    
Application event log can be full. –  Sergey Sep 18 '11 at 22:39

Check to make sure your SQL Browser service is running as well. That was the issue with my instance.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.