Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I have a set of two VM's which I am trying to use puppet on. It's about a simple setup as you can get, I am trying to setup a server and setup a client and simply get to writing some puppet policy.

I am using a fresh install of CentOS on the client and the server. I am using the EPEL repos. I tried following the following guide: http://www.how-to-linux.com/2009/02/how-to-install-a-puppet-master-and-client-server-on-centos-52/ I have also referenced the puppet documentation

Server I set the hostname to puppet.apt15 in /etc/sysconfig/ I set the ips for both client and server (in both the client and server) /etc/hosts

192.168.2.5             puppet
192.168.2.4             puppet-db
127.0.0.1               localhost.localdomain localhost
::1             localhost6.localdomain6 localhost6

I have tried several combinations including the apt15 and not including it. I have reinstalled everything from scratch on both twice. This is the error I get:

[root@puppet-db ~]# puppetd --test
warning: peer certificate won't be verified in this SSL session
info: Caching certificate for puppet-db.apt15
err: Could not retrieve catalog from remote server: certificate verify failed
warning: Not using cache on failed catalog
err: Could not retrieve catalog; skipping run

I have installed ntpd, and run ntpdate on pools.ntp.org on both machines. This was however after the installs and attempts to connect. But I cleared the /var/lib/puppet.ssl folders several times on the client and server and ran puppet-ca --clean :all on the server. I have also tried the process with setenforce 0 (SELinux off) and the firewall off

I am at my wits end. Can I turn SSL authentication off so I can just work with writing policy?

I fear something is wrong with my DNS\hostname settings and this is just a basic setup. I don't care about security right now, I just want something I can start working with so I can learn it. I don't have any official domains i.e. something.mysite.com which a lot of other guides seem to assume.

share|improve this question
2  
What, if anything, is in /var/log/messages on the PuppetMaster VM? That might tell you if the connection is even being made. Also, what does puppetca --list --all show on the PuppetMaster? –  Jeff Leyser Jun 26 '10 at 18:12
    
Thank you for your comment. –  Joshua Enfield Jun 26 '10 at 18:23

1 Answer 1

up vote 1 down vote accepted

I got it, I did everything from scratch again, but made sure before even beginning the tutorial in the article I did the following on the server and client:

/etc/hosts
192.168.2.5             puppet-db.apt15 puppet-db
192.168.2.4             puppetmaster.apt15 puppetmaster puppet
127.0.0.1               localhost.localdomain localhost
::1             localhost6.localdomain6 localhost6

/etc/sysconfig/network Set hostname to [server name].apt15

yum install ntp
ntpdate pool.ntp.org
ntpd
shutdown -r now (then login)
setenforce 0

Then start tutorial I also had to use puppetd --server myserver.domain.com --waitforcert 60 --test from the documentation instead of the lines in the guide to get the certificate signed and accepted.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.