Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

Does IIS7 not support ASP.NET - by default?

i put asp.net files in there, but it says 404 - not found.

And finding out

  • if it's disabled
  • if it can be disabled
  • if it's enabled
  • if it can be enabled
  • if it's supported
  • if it's not supported
  • if it's supported but not enabled
  • if it's not supported but possible to enable...

is like pulling teeth.

Edit: I'm really getting tired of Microsoft's "broken by default" policy.

share|improve this question
1  
not "broken by daefault" but "secure by default" - turn on what you need. THis is standard practice in unix for 20 years, recently adopted by MS.... to avoid possible bugs in subsystems you dont really want to run anyway becvause you do not use them. –  TomTom Jun 27 '10 at 9:20
    
One could argue, that if i didn't want a IIS running, i would not have installed it. –  Ian Boyd Jul 1 '10 at 4:04
1  
One thing is having IIS installed as a static file server (HTML) and another very different one is having ASP.NET enabled that allows executing dynamic code in the server. As TomTom mentions, this is a best-practice in EVERY platform, minimize the surface attack and let users choose what they need. You could imagine that if you were a PHP developer you could not care less about ASP.NET and why pay the overhead and perf-hit if you will never use it. –  CarlosAg Jul 6 '10 at 2:50
    
@CarlosAg Why? Take a random sampling of IIS web-server. See how many are serving ASP/ASP.net. The default install should be what the majority want it to be. "Reasonable defaults" (Take a random sampling of installed SQL Servers. How many are connected to from another machine.) –  Ian Boyd Jul 7 '10 at 15:58

1 Answer 1

up vote 3 down vote accepted

You have to enable it. In IIS6 and earlier, you had to install .NET, in IIS7 you have to enable it.

If you already have IIS enabled, right click on My Computer, go to Manage, then Roles \ Web Server (IIS). On the right hand side, click "Add Role Services", make sure you enabled ASP.NET and .NET Extensibility under Application Development.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.