Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

Problem: I am trying to run a webserver from my computer. I see the request getting to the server, but am unable to see the page on the browser due to a "Errno 10054: An existing connection was forcibly closed by remote host" in my server logs. Firefox displays "The connection was reset". Below describes my current setup:

Setup: SpeedTouch ST516 (modem) in bridged mode --> DI-524 Router set up in with PPPoE connection. On my router, I have setup port 80 to be forwarded to 192.168.0.101 (my computer's IP address). I have started my webserver server on 192.168.0.101:80.

Scenario: When I go to my browser and type in http://myextIP, I see the request getting to the server, an even see a "GET / HTTP/1.1" 200, but a few seconds later displays an "Errno 10054: An existing connection was forcibly closed by remote host". I have disabled the Windows firewall, but have unable to resolve this problem. Any help would be greatly appreciated.

Thanks

share|improve this question

3 Answers 3

up vote 2 down vote accepted

Try it from a different location that originates outside your network. Not that hard to do at a moments notice: go to Google's language translation service and request that it translate a page on your web server.

It's tricky to get firewall rules just right so that packets that originate inside end up coming back in in the right way.

share|improve this answer
    
Fantastic! Never thought of using Google translate as an external source. Google Translate manages to display the page with text only. It takes around 10 second from the point when I press enter in the address bar to see the request in my server. The "An existing connection was forcibly closed by remote host" still happens. However, I will be replacing the route anyways- will see if that improves the situation. Thanks again! –  Derek Kwok Jun 27 '10 at 21:44
    
Good idea. The router you are using was discontinued 2.5 years ago. Try getting something you can install OpenWRT/DD-WRT/etc on. Also, don't forget that your ISP may not like their customers running a web server and may be the cause of all this. If possible, run wireshark to determine where the termination packets are coming from. Get a friend to connect to your web server and have them also capture the packets of their http conversation. I bet it's your ISP and that they are using some combination of logwatch (by the delay) and then cutter to sever the connection. –  Allen Jun 27 '10 at 23:34

I've come across home routers that just cannot handle this sort of routing. Have you tried asking a friend to view your page from someplace outside of your network?

I'm assuming http://192.168.0.101/ works, right?

share|improve this answer
    
Yep! 192.168.0.101 works fine. Friend is also unable to see page. Please see the comment I left in Allen also. –  Derek Kwok Jun 27 '10 at 21:44

If it's a question of testing from outside then you could set up VNC on some external computer (i.e. your home computer) and connect to it. To do this you should probably install something like stunnel (see www.stunnel.org) and set it up to forward your localhost:5900 to home_ip:443 and at home collect from 443 and forward to 5900. This way you get a tunnel over HTTPS without really installing anything (you can simply copy stunnel files).

You'll find an example setup files here (just change 7777 to 443): http://faq.gotomyvnc.com/fom-serve/cache/33.html

Remember that you should generate your stunnel.pem and copy to both machines to make your connection really secure.

After setting up stunnel you simply install VNC server at home with default options and run VNC viewer at your job. What might be counter-intuitive at first is that you connect to localhost. This is because stunnel does the forwarding.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.