Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

Hey guys I just finished installing clamAv on my vps that runs Centos. For some reason server interactions slow way down even when I am not calling on ClamAv (clamascan) directly but accessing php files under the root directory (in folder in root directory) even if they are blank files. However when my site is idol, cpu usage is fine. Does anyone know how to prevent this from happening, or has experienced a similar issue? Any advice whatsoever is greatly appreciated.

SOLUTION:

ok the solution was to put a php.ini file in each folder, but if anyone could tell me why this could possibly be I will give them the bounty

share|improve this question
1  
How exactly did you install clamav? Did you do anything like installing mod_clamav? –  Zoredache Jun 28 '10 at 0:38
    
no I did not, I simply used the yum package install and used freshclam to update the database. the cpu has been spiking in some places and killing the cpu where it normally would not with clamav disabled. It says the cpu spike is because of a php script, but it does not seem like this is the case because I tried submitting a form to an empty page and still got a huge spike. –  Scarface Jul 5 '10 at 15:10
    
Zoredach? Anyone lol? I am trying everything here and this problem is killing me lol. –  Scarface Jul 5 '10 at 20:38
    
ok I found the slowdown seems to only happen when accessing files under the web directory –  Scarface Jul 5 '10 at 20:58
    
Did you install a shim that scans-on-filesystem-access? Something like one of these?: openantivirus.org/projects.php clamfs.sourceforge.net clamfs.sourceforge.net –  Avery Payne Jul 6 '10 at 22:48
add comment

1 Answer

up vote 1 down vote accepted

The problem was that the php ini in my home directory did not affect all levels of files so for some reason clamav slowed down when accessing files within a folder because the default php ini was used so the solution was to mod the htaccess by using suphp_configpath and specifying the directory the php ini is.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.