Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I'm running the following:

  • OSX 10.6.4

  • Subversion 1.6.12 (Collab.net package)

  • Apache 2.2.14 (default install that came with OSX 10.6.4)

Steps I've completed:

  • turned on Apache (web sharing in OSX)
  • tested it via the LAN url it gives me (works on my machine and others)
  • installed Subversion
  • configured subversion as such: http://blogs.open.collab.net/svn/2009/05/building-an-os-x-based-subversion-server.html which entails:
    • added subversion module to apache (dav_svn_module)
    • set up path for repos directory in apache
  • created repository (/opt/repos/svn/text)
  • modified /opt/repos/svn/text/conf/passwd to add users/passwords
  • restarted apache

And...that's where we're stuck.

How do I now access said repository? We've tried both local and remote IDEs. Both systems can access my hxxp://computernameurl/ in a web browser, but fail within the IDE when trying to connect to the subversion repository.

I'm stuck as to what I should be testing/looking for at this point.

EDIT: (more info)

Well, I THOUGHT Apache was running, but it turns out to be Firefox doing some silly local caching.

So, the issue is that Apache wasn't running. Deleting the updated config text fixes it, so there is clearly something amiss with the configuration file updates. The updates per the link above are:

# Load Subversion Apache Modules
LoadModule dav_svn_module /opt/subversion/lib/svn-apache/mod_dav_svn.so

# Work around authz and SVNListParentPath issue
RedirectMatch ^(/repos/svn)$ $1/

# Enable Subversion logging
CustomLog logs/svn_logfile "%t %u %{SVN-ACTION}e" env=SVN-ACTION

<Location /repos/svn/>
 # Enable Subversion
 DAV svn

 # Directory containing all repository for this path
 SVNParentPath /opt/repos/svn

 # List repositories collection
 SVNListParentPath On
</Location>

Does anyone see anything wrong with that text that would break Apache? I placed that immediately after the current list of LoadModule commands in httpd.conf.

share|improve this question

1 Answer 1

up vote 1 down vote accepted

1) don't add stuff to httpd.conf. Create your own .conf file and put it in /private/etc/apache2/other/

2) Do 1) then attempt to start Apache, the check the system logs, Apache should be telling you what line in the config file it doesn't like.

share|improve this answer
    
thanks peelman. Turns out the issue it that I was telling Apache to put the SVN log files in usr/logs. Alas, logs wasn't a directory that existing. Creating the directory first fixed things. –  DDD Jun 29 '10 at 20:33
    
I just experienced a similar problem over the weekend, with the same cause, I was feeding apache a relative path instead of the full one. Glad you hear you got it figured out though! –  peelman Jun 30 '10 at 2:36

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.