Server Fault is a question and answer site for system and network administrators. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

hostname -f says "hostname: the specified hostname is invalid". The hostname (FQDN) specified in /etc/hostname is also listed in /etc/hosts and is pingable. No actual DNS server yet of the host knows. Is this a reason of the error reported or something else? (the OS is Ubuntu 10.04 Server).

Update: registering the host at a DNS server (so that the name can be successfully resolved via Internet) did not help.

share|improve this question
Well... what's the contents of /etc/hostname or do we need to guess that too? – rodjek Jun 29 '10 at 5:06
Please share the contents of your /etc/hostname and /etc/hosts. Maybe the hostname is in fact invalid. – David Jun 30 '10 at 7:34

From this thread on Ubuntu Forums.

Apparently the underscore is an illegal character for hostnames. I had one in my hostname, and it gave me your failure message. Maybe you're getting something similar.

share|improve this answer

/etc/hostname should only contain the hostname and not a full FQDN.

share|improve this answer
Tried this. No difference. – Ivan Jun 30 '10 at 6:49

Check the configuration of:


host.conf should have "order hosts, bind" and nsswitch.conf should have "hosts: files dns" at a minimum. Possibly you've got something out of whack that's searching only DNS and not your local files?

share|improve this answer
clearly not the problem. – hop Jun 29 '10 at 21:51
Al that's there. – Ivan Jun 30 '10 at 6:50
solved the problem for me, Host \209\149something.sld.tld returned servfail - it looked ok though, osx terminal injecting funny things again ;) – ZaphodB Apr 8 '11 at 22:03

hostname -f relies on DNS working.

What does:

host `cat /etc/hostname`


share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.