Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I installed SQL Server 2008 and typed in an instance name of sql2008 but it seems to have been isntalled as a default isntance. Trying to connect using .\sql2000 fails but using just the computer name succeeds. The service is listed with (MSSQLSERVER) as if it is the default instance, but the data directories all have the .sql2008 instance name suffix. So not only is it not what I wanted, but the data directories and service names have inconsistent suffixes. Was there something else I needed to do besides specifying an instance name during installation? Maybe a checkbox I missed?

Is there a way to change from a default instance to a named instance?

share|improve this question

2 Answers 2

Not easily (if at all). You're best off reinstalling. I'd have to go through the installer again, but if you didn't select the Named Instance option it could still let you type in the name for a named instance but leave the option set for the default. Reinstall and double check all the options as you're doing the new install.

share|improve this answer

Looks like you changed the instance file locations, not the instance name. These are distinct options configured during setup. See File Locations for Default and Named Instances of SQL Server.

If your instance must be named sql2008 then you'll have to install it again from scratch. There is no procedure to rename an instance.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.