Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have an MSSQL 2000 instance installed and running on VMWare (not my choice, but mandated to me) ... It's been running fine because I've cut my teeth a few times performance tuning it. This sql instance is also isolated from other VMWware hosts so its the only application using the hardware. Recently however, sqlserver has been bombing out on me when I run a simple backup of a database that is 30GB in size. What is really curious is that this backup has run in 10 minutes time in the past. I've made sure no other DTS tasks or processes are running when I run this backup. What happens is that the backup just never finishes ... it just keeps running for hours! Anyone else out there experienced this and have any ideas? Switching from sql or vmware is not an option for me.

share|improve this question
    
How big is the database's .MDF and LDF file? –  Philip Fourie May 30 '09 at 15:55
2  
How much RAM? How is max ram configured in the SQL instance? You say "bombing out", does it die or do you kill it? Plenty of disk space? I know you can't change, but does it make sense to have it be a VM if it tying up a host being a dedicated server? –  SqlACID May 30 '09 at 16:13

3 Answers 3

I doubt this has anything to do with VMware but more likely an issue with your database. You're best to start to troubleshoot the source of the problem. You could mount the database on a physical server and attempt a backup to confirm whether the problem lies within the server itself or in the database.

Another option might be to dump the database and then rebuild it in a fresh database file on your existing server.

share|improve this answer

What version of VMWare? Server or ESX?

Are you using a VHD or directly accessing the hard drive?

Have you tried running other backups from other databases on the same server? Have you tried other options in the backup? Different destination, different options? Have you tried it from the OSQL commandline, just as a differnet way of executing? Anything from the event log?

share|improve this answer

Run Performance Monitor and watch the CPU time, Avg disk queue and disk bytes per second. That should pin down where the bottleneck is.

JR

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.