Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have a ISC DHCP Server installed on Ubuntu 9.10 . I have managed to successfully boot a PXE client , obtain a DHCP address and load the initrd.gz file. But I am facing a vague problem when the debian installer starts up and tries to get a DHCP server

The client send a DHCP request and I verified that is the same MAC Address. But I get a DHCP DECLINE (The client declines the address ). It offers all the address in the pool and then there is a DHCP NAK (no more free leases )

I tried using the Option no-ping, and also option one-client-one-lease but it does not help .

If I set the client to use a fixed-address then the above problem is not there and the installation proceeds smoothly

Can you give me any clues on what should be the DHCP server configuration

My dhcpd.conf looks like this

{
    ddns-update-style none;
    option domain-name "hadoop-myorg.org";
    option domain-name-servers 192.168.3.5;
    default-lease-time 600;
    max-lease-time 7200;

    group {
        filename "pxelinux.0";
        next-server 192.168.13.184;
        host hadoop1 { hardware ethernet 90:e6:ba:d5:53:f8; }
    }

    subnet 192.168.13.0 netmask 255.255.255.0 {
        option routers 10.0.0.254;

        pool {
            option domain-name-servers 192.168.3.5;
            max-lease-time 3000;
            range 192.168.13.55 192.168.13.65;
            deny unknown-clients;
        }
    }
}
share|improve this question
    
(Just a guess) Sounds like something wrong with the PXE implementation on the NIC as the installer should just pull the IP from the PXE Table, not request another from the DHCP server. –  Chris S Jun 30 '10 at 15:54
    
Add logs please –  bindbn Sep 29 '10 at 14:38
    
I've had this problem, but i cant for the life of me remember what i did to fix it ...grrrrr :-). Try using a different dhcp server and see what results you get. If things get desperate you could always set a static ip address for you debian installer. –  The Unix Janitor Oct 14 '10 at 8:51

5 Answers 5

What version of syslinux are you using (syslinux provides your pxelinux.0 file)? If it's not recent, try upgrading.

Are you using IPAPPEND 1 in your pxelinux.cfg file? This tells pxelinux to explicitly pass the IP address and gateway to the installer.

One issue I see with your configuration is your router value is outside the DHCP subnet. That's probably not going to work like you want it to, and may very well be why the installer is rejecting it. The value for 'options routers' should be your gateway. For the most common network setup, that would be 192.168.13.1

share|improve this answer

Have close look at an ifconfig on the DHCP server. Make sure broadcast & netmask are correct.

share|improve this answer

It seems to be an client problem why it's declining the address. Is it well configured to use a DHCP address. Try runing dhclient manually.

share|improve this answer

You supplied router from outside the DHCP network. Maybe the client validates data and rejects this configuration?

share|improve this answer

I have had this same problem with isc-dhcpd on Ubuntu 9.10. Ultimately I upgraded the operating system and a new isc-dhcpd-server package shipped with it.

A little more information might be helpful here, but it looks like a client side issue to me. A similar thing sometimes occurs with poorly implemented tftp clients in pxe boots, but I don't think you've gotten to the pxe part yet, right?

If you have access to it- try running gpxe on the client. It is installed in many BIOS systems now. Also, dhclient and wireshark can be used to troubleshoot the dns. The old fashioned way would be to try it on a different subnet with a different dhcp implementation such as Junipers or even MS Windows. Also, make sure there really is only a single dhcp server running on your subnet at once, or this can cause confusion.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.