Server Fault is a question and answer site for system and network administrators. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

We have a WS 2008 R2 running on a laptop which has a WS2008 R2 vhd running on it. We tried to add hyper-v tools to the base OS today and it now blue screens when you try and boot the base OS. We can boot in safe mode but can not seem to remove / disable the feature from there.

The blue screen mentions "impcd.sys", (I am not great at reading them).

Does anyone have an idea as to how we can fix this issue? We would rather not reinstall the base OS.

btw, the reason we did this is because we wanted to increase the size of the VHD from 50GB hard drive to 100GB, but not got that far yet.


We managed to eventually get it working via lots of fiddling with safe boot and network safe boot. Some how it managed to fix it self partly so we could boot and remove the hyperv feature.

Tried to reinstall to see if it was a random bad install but still broken... So fiddled with it again to remove it (still took ages, not 100% sure how we got it working tbh).


share|improve this question

Just a thought, but first, does the laptop support virtualization? And if so, did you enable in the BIOS?

share|improve this answer
Hi, yep, the VHD has been working fine and the bios enabled. We needed to expand the drive size and thought this might work. – Jon Jun 30 '10 at 16:24

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.