Server Fault is a question and answer site for system and network administrators. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I want to add the original ISO I installed RHEL from as a repository under the Add/Remove Software tool in Gnome.

How do I do this?

To clarify, I know what I need to do (add a repository) - I need the how. I have been unsuccessful in determining the correct string to put in the location field in the Gnome applet. Currently I have file:///media/rhel/Server/repodata. I have tried pointing directly to the XML file in that directory, the parent directory, its parent, and in variations with more and less slashes in the path.

Update: I found, which has directions for creating the repository manually - but I don't see why this should be needed if the repomd.xml file is already on the DVD.

share|improve this question
have you run the createrepo command? – user152916 Jan 10 '13 at 23:19
up vote 5 down vote accepted

Hey after searching around I was able to find a better understanding answer to this problem.

Make a mount point for your iso:

mkdir /mnt/pen

Mount the OS installation iso like normal:

mount -o loop rhel.iso /mnt/pen/

Create a details entry for your repository (add a file in the /etc/yum.repos.d directory e.g. rhel.repo):


name=Red Hat OS CD




Clean your cache:

yum clean all

You should now have your repository visible in Add/Remove Programs.

NOTE: You might want to consider automounting your iso.

share|improve this answer

Loopmount the iso under /mnt, then add a .repo file in /etc/yum.repos.d whose baseurl points to the mountpoint.

share|improve this answer
Ignacio - that is the "what", which I know (see original question): I need the "how". Specifically, I am trying to do this with the Gnome "Add/Remove Software" applet. I've added to the question to clarify. – warren Jul 1 '10 at 13:02
The correct path is the one that contains the repodata/ directory. yum looks for its presence in order to find the repo data. – Ignacio Vazquez-Abrams Jul 1 '10 at 14:46
That is the path I've been trying to add (/media/rhel/Server/repodata). The error kicked-back from the applet is "Cannot retrieve repository metadata (repomd.xml) for repository: DVD. Please verify its path and try again." – warren Jul 1 '10 at 17:00
Contains. Not is. As in, use /media/rhel/Server. – Ignacio Vazquez-Abrams Jul 2 '10 at 4:03
:-\ tried that too, still getting the same error :( – warren Jul 2 '10 at 14:21

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.