Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

This is a new issue to me and has been driving me nuts for the past hour or two. I have an Apache server running on port 8000 (confirmed in ports.conf and by nmap) yet any request to it is automatically redirected to port 80 (specifically, the port is dropped so 80 is default); the request is then refused.

Things I have tried:

  • Checked Apache configurations
  • Disabled mod_rewrite
  • Checked iptables (and disabled to be sure)

Here's me running wget against it just so you can see what exactly is happening

--2010-07-01 04:02:14--
Connecting to connected.
HTTP request sent, awaiting response... 301 Moved Permanently
Location: [following]
--2010-07-01 04:02:15--
Connecting to failed: Connection refused.
zsh: exit 4     wget

Anybody have suggestions? At this point I can't even figure out what is causing the redirect, much less the port drop.

share|improve this question
up vote 0 down vote accepted

Seem to be an issue with your httpd.conf file (there is clearly a redirection (301)) Have you checked whether there are other default httpd-module files included by default? Example: conf.d/php.conf --- conf.d/welcome.conf

share|improve this answer
Turns out this was caused by an idiotic piece of software redirecting traffic based off a setting. It didn't have anything do with Apache, but you're technically correct so √! – user8585 Jul 1 '10 at 21:55

Out of my head and without actually knowing what your configuration looks like, put this to your httpd.conf and restart apache:

UseCanonicalName off
share|improve this answer
Yeah, tried that too; wasn't it. (see above comment) – user8585 Jul 1 '10 at 21:53

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.