Server Fault is a question and answer site for system and network administrators. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

On my CentOS 5.2 box running Samba (3.0.33-3.29) I created a folder called /upload.

In samba I configured a share like this:

        comment = upload folder
        path = /upload
        valid users = kevin root
        public = yes
        writable = yes
        browsable = yes
        create mask = 0777
        directory mask = 0777
        guest ok = yes

I chown'd the /upload folder to my account 'kevin' and checked that I could create files and folders via the shell.

I can browse to the machine from Windows 7, authenticate as 'kevin' and see my home directory share and the upload share but I can't access them.

Windows reports:

Network Error

Windows cannot access \\cos-01\upload

Check the spelling of the name. Otherwise, there might be a problem with your network. To try to identify and resolve network problems, click Diagnose.

Error code: 0x80070035
The network path was not found.

This is a check list of what I've done:

  • the account kevin was added to samba using smbpasswd -a kevin and setting my password at the same time. The samba and centos passwords are both the same.
  • the server name cos-01 is in the /etc/hosts file i.e.  localhost localhost.localdomain  cos-01
  • I've also set the netbios name in /etc/samba/smb.conf
  • I configured Windows 7's LAN Manager authentication level to "Send LM & NTLM - use NTLMv2 session security if negotiated"


I tried accessing the share by both IP address and server name i.e. \cos-01\upload or \\upload. In both cases I get the same error as detailed above.

I checked the /var/log/samba/smbd.log logfile and see lots of:

[2010/07/02 16:56:10, 0] smbd/service.c:make_connection_snum(1013)
  '/upload' does not exist or permission denied when connecting to [upload] Error was Permission denied
share|improve this question

Is SELinux active? If it is, then you can make it accessible by setting the type to public_content_t. If samba should be able to write to it, then set the type to public_content_rw_t. Note that if you do the latter, you will also need to tell SELinux about this; my system-config-selinux has a boolean for this: Allow Samba to write files in directories labeled public_content_rw_t

share|improve this answer
Hi Kevin - SELinux is enabled (enforcing/targeted). I don't seem to have a system-config-selinux tool though. Can I set this using setsebool allow_smbd_anon_write 1, is that the same? – Kev Jul 2 '10 at 16:16
Ok...needed to yum install policycoreutils-gui to get system-config-selinux...however this is a server and I'm guessing this is a gui based tool? – Kev Jul 2 '10 at 16:26
system-config-selinux is indeed a gui based tool. If I run that on my server and toggle the option, I find that getsebool allow_smbd_anon_write returns toggled results. So I would run that command and see if it does work. – Kevin M Jul 3 '10 at 15:22
setenforce 0 - will test if it's SELinux causing the problem. A restart or setenforce 1 will turn it back on. – Joshua Enfield Dec 2 '10 at 3:25

There's some additional information you will need to provide to answer this question.

I chown'd the /upload folder to my account 'kevin' and checked that I could create files and folders via the shell.

  • Did you do this chown as root, or as kevin, or as some other account?
  • What is the group currently assigned to the directory?
  • What is the directory's mode? Is the execute bit set for the user and group?

I can browse to the machine from Windows 7, authenticate as 'kevin' and see my home directory share and the upload share but I can't access them.

  • Is your Windows 7 machine a member of the same workgroup as the Samba server?
  • Is the server a member of a domain, is it a domain controller, or is it a stand-alone server? If your Windows 7 machine is in a domain you'll want to consider joining the server to the domain as well. While not necessary, it will help with authentication.
  • What is the security = setting currently at in /etc/samba/smb.conf? If your Samba server is a member of a domain it should probably be security = ads; if your Samba server is stand-alone it should probably be either security = user or security = share.
  • Do you have an entry for client signing = no? (You may need yes instead when connecting with newer Windows clients)
  • Do you have an entry for client use spnego = no? (You may need yes instead when connecting with newer Windows clients)
  • Is winbind running? If your server is not a domain member or a domain controller this may cause a bit of confusion while running; stand-alone servers do not need this service.
share|improve this answer
thanks for the answer, I'll check this out when I get a moment to turn my attentions back to this. – Kev Jul 13 '10 at 12:24

Try this, it helpedme

  • Enable NetBIOS over TCP/IP
  • Select Authentication level
  • SMB Signing
  • ‘Client for Microsoft Networks’
  • Network Binding Order
share|improve this answer
Please include the relevant pieces of info of the link in your answer.The link might go dead one day and then your answer will be useless. – Lucas Kauffman Apr 5 '12 at 19:14
Like it has? ... – Moshe Sep 9 '12 at 3:13
@Moshe Maybe pay attention to the edit date and the date of the comment? – HopelessN00b Nov 5 '12 at 19:15

Hmm, this would normally mean that the local path /upload (so, upload in the root of your servr) does not exist on you server.

share|improve this answer
The folder definitely exists – Kev Jul 2 '10 at 15:55

Try to access the samba server with ip address instead: \_ip_address_of_samba_server_\upload

Also check samba logs in /var/log/samba/log.smbd and see, if the windows client really tries to log in. Otherwise, there is problem with network. And the error seems like it..

Best regards,


share|improve this answer
Hi Martin - I just updated my question with answers to your suggestions. Cheers. – Kev Jul 2 '10 at 16:01
Hello Kev, sorry for my late react, I wasn't here for a while. Is the configuration correct (try command testparm)? Have you tried to mount the share from linux (via smbmount)? – mkudlacek Jul 7 '10 at 8:04

What does smbclient say, if you try to connect via localhost? Same errors, or just SNAFU? And what lines do smbclient and windows share browsing create? Have you tried to login as a nobody, to see that your directory is reachable.

And last but least....

In which it is recomended that securitylevel is downgraded from (new) 128-bit, allowing connections to older and more compatible versions of windows sharing.

-- Here goes nothing.

share|improve this answer

protected by Chris S Apr 5 '12 at 13:00

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.