Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

so I can connect to my EC2 instance as root but if I create a user I get a Permission denied(public key) error. here is the output from ssh -v

OpenSSH_5.3p1 Debian-3ubuntu3, OpenSSL 0.9.8k 25 Mar 2009 debug1: Reading configuration data /etc/ssh/ssh_config

debug1: Applying options for *

debug1: Connecting to 184.72.242.226 [184.72.242.226] port 22.

debug1: Connection established.

debug1: identity file /home/amaro/.ssh/identity type -1

debug1: identity file /home/amaro/.ssh/id_rsa type 1

debug1: Checking blacklist file /usr/share/ssh/blacklist.RSA-2048

debug1: Checking blacklist file /etc/ssh/blacklist.RSA-2048

debug1: identity file /home/amaro/.ssh/id_dsa type -1

debug1: Remote protocol version 2.0, remote software version OpenSSH_5.1p1 Debian-6ubuntu2

debug1: match: OpenSSH_5.1p1 Debian-6ubuntu2 pat OpenSSH*

debug1: Enabling compatibility mode for protocol 2.0

debug1: Local version string SSH-2.0-OpenSSH_5.3p1 Debian-3ubuntu3

debug1: SSH2_MSG_KEXINIT sent

debug1: SSH2_MSG_KEXINIT received

debug1: kex: server->client aes128-ctr hmac-md5 none

debug1: kex: client->server aes128-ctr hmac-md5 none

debug1: SSH2_MSG_KEX_DH_GEX_REQUEST(1024<1024<8192) sent

debug1: expecting SSH2_MSG_KEX_DH_GEX_GROUP

debug1: SSH2_MSG_KEX_DH_GEX_INIT sent

debug1: expecting SSH2_MSG_KEX_DH_GEX_REPLY

debug1: Host '184.72.242.226' is known and matches the RSA host key.

debug1: Found key in /home/amaro/.ssh/known_hosts:1

debug1: ssh_rsa_verify: signature correct

debug1: SSH2_MSG_NEWKEYS sent

debug1: expecting SSH2_MSG_NEWKEYS

debug1: SSH2_MSG_NEWKEYS received

debug1: SSH2_MSG_SERVICE_REQUEST sent

debug1: SSH2_MSG_SERVICE_ACCEPT received

debug1: Authentications that can continue: publickey

debug1: Next authentication method: publickey

debug1: Offering public key: /home/amaro/.ssh/id_rsa

debug1: Authentications that can continue: publickey

debug1: Offering public key: atkey.pem

debug1: Authentications that can continue: publickey

debug1: Trying private key: /home/amaro/.ssh/identity

debug1: Trying private key: /home/amaro/.ssh/id_dsa

debug1: No more authentication methods to try.

Permission denied (publickey).

any help would be appreciated.

share|improve this question
    
Did you add the ssh key to the user, too? Depending on the image only key authentication is enabled. –  TooAngel Jul 2 '10 at 16:00
    
hey which key are you referring to? Ive added the /.ssh/authorized_keys as well as the private and public key parts –  user47412 Jul 2 '10 at 16:13

1 Answer 1

found the solution had to set permissions to 700 on the .ssh keys thanks for the help

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.