Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have just installed Monitorix on ArchLinux using the tutorial here: wiki.archlinux.org/index.php/Monitorix

I am using the Lighttpd web server.

It is working fine and the graphs are being generated, but instead of text on the graphs its replaced by 'boxes' like the language is missing or something. See picture here:

Picture of bad graphs: http://cl.ly/99929108eeabf3ed72da/

My /etc/monitorix.conf file is using "en" as the laungage:

# General
our $TITLE = "Hodge Inc.";              # your company name
our $HOSTNAME = "hodge-fs";             # hostname of this server
our $OSTYPE = "Linux-Arch";             # choose your OS type (see below)
our $SAMBAVER = "3";                    # Samba version (2 or 3)
our $MULTIHOST = "N";                   # Enable multihost feature
our $MULTIHOST_FOOTER = "N";            # (multihost) display URL in image
our $MULTIHOST_IMGPERLINE = "2";        # (multihost) # of images per line
our $REPORT_LANG = "en";                # Report language

Any ideas?

share|improve this question
up vote 0 down vote accepted

I solved this by installing the terminus-font package.

I also updated the ArchLinux wiki here: http://wiki.archlinux.org/index.php/Monitorix

share|improve this answer

I encounter this problem also. terminus-font don't fix my problem. After some check, it say somewhere online, this related missing mono font.

So, my solution is that, first check font list with

fc-list

On my system, this show empty fc-list. It need install some mono font by doing following command

apt-get install fonts-inconsolata fonts-freefont-otf fonts-freefont-ttf  fonts-jura  fonts-tlwg-mono
fc-list :spacing=mono

This time it show some mono font. Not all four fonts should use. Only one should be enough.

After restart monitorix and clean existing picture. It works, cheer!

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.