Server Fault is a question and answer site for system and network administrators. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

We're spinning up some Ubuntu servers on Amazon EC2 but given the firewall restrictions we have within our corporate network we can't ssh out to them (even tried running ssh server on a different port - still doesn't work). Are there web apps out there that can expose a command-prompt like interface via a browser that would just require HTTP access? Obviously we'd need to lock this down fairly tightly. Any ideas?

share|improve this question
Have you tried talking to the person who is responsible for the firewall? It seems incredibly silly to setup a web app in place of SSH which is far better tested and focused on security. Surely they could setup an exception for connecting to your web host. – Zoredache Jul 3 '10 at 4:57
This may or may not be a stupid question, but have you double-checked your EC2 security groups to ensure that you are allowing inbound TCP/22 (or TCP/whatever) traffic from your corporate network's egress IP? Also, I'm not sure what alternate port you moved SSH to, but it's very unlikely that your corporate firewall will block outbound TCP/80, so try temporarily moving SSH to that, just to see if it works where TCP/22 doesn't. – Eric Dennis Jul 3 '10 at 5:08
@Zoredache - I know it does sound silly, but it's a multi-national company and the network is large and complex and they apparently can't make exceptions for certain machines. @Eric - Yes I tried running SSH on port 80 as well but the firewall does block it (works though connecting from my home machine). I believe the firewall is doing packet-level inspection of protocols and blocking ssh on whatever port it tries. – Marplesoft Jul 3 '10 at 12:25
run it on 443. Assuming you're not using a https proxy, it'll just see encrypted traffic going through, as it expects. – Cian Jul 3 '10 at 15:16
That didn't work either. I probably left out something important though, we also use a proxy server. So it's possible that the proxy server is blocking the request before it gets to the firewall maybe? – Marplesoft Jul 4 '10 at 15:17
up vote 2 down vote accepted

Try AjaxTerm or Shell In A Box.

share|improve this answer

I use PHP Shell Terminal sometimes.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.