Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I am currently in the Process of moving from one server to another. And I am currently setting up my apache2. However on the old server I used several subdomains. Now i wanted to test these subdomains on the new server, however it seems hat subdomain.xx.xx.xx.xx (subdomain.ip-address) does not seem to work. Is this impossible or is it just me getting the config wrong?

my config

NameVirtualHost *:80
<VirtualHost *:80>
ServerAdmin webmaster@localhost
DocumentRoot /var/www/tld.com
<Directory>
    Options FollowSymLinks
    AllowOverride None
</Directory>
<Directory /var/www/tld.com>
    Options -Indexes FollowSymLinks MultiViews
    AllowOverride None
    Order allow,deny
    allow from all
    # This directive allows us to have apache2's default start page
            # in /apache2-default/, but still have / go to the right place
            #RedirectMatch ^/$ /apache2-default/
</Directory>
ScriptAlias /cgi-bin/ /usr/lib/cgi-bin/
<Directory "/usr/lib/cgi-bin">
    AllowOverride None
    Options ExecCGI -MultiViews +SymLinksIfOwnerMatch
    Order allow,deny
    Allow from all
</Directory>

ErrorLog /var/log/apache2/error.log

# Possible values include: debug, info, notice, warn, error, crit,
# alert, emerg.
LogLevel warn

CustomLog /var/log/apache2/access.log combined
ServerSignature On

Alias /doc/ "/usr/share/doc/"
<Directory "/usr/share/doc/">
    Options Indexes MultiViews FollowSymLinks
    AllowOverride None
    Order deny,allow
    Deny from all
    Allow from 127.0.0.0/255.0.0.0 ::1/128
</Directory>
</VirtualHost>
<VirtualHost *:80>
    ServerAdmin webmaster@localhost
    DocumentRoot /var/www/subdomain
    ServerName subdomain.62.75.145.146
</VirtualHost>
share|improve this question
add comment

1 Answer 1

up vote 2 down vote accepted
  1. Make sure that your subdomain is pointing to the correct IP.
  2. Ensure that the subdomain is listed as a host in your virtualhost config, either ServerName or Server Alias.

If either of these don't solve the problem, you're going to need to give us more info - post your apache vhost config at the very least.

--Edit-- Okay, first off, subdomain.62.75.145.146 is not a valid DNS name. You cannot just add on arbitrary hostnames to your server's IP address. You need to either have a dedicated IP for this virtualhost or assign a valid DNS name. If you're just doing testing, you can just add an entry to the hosts file on your client mapping subdomain.example.com to 62.75.145.146. That line would look like this:

62.75.145.146    subdomain.example.com

Then set subdomain.example.com as the ServerName in your VirtualHost. At that point, you should be able to visit subdomain.example.com in your browser and it will serve from the correct vhost.

If the hosts file is not a good solution for you, you'll need to create a proper DNS A or CNAME record for the subdomain. The process for doing that it outside the scope of this question, but there should be plenty of info in other ServerFault articles about that process.

share|improve this answer
    
Added my config –  niklasfi Jul 3 '10 at 17:42
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.