Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I am trying to configure openSUSE 11.2 "Emerald" for Remote access, and having a problem

What I have done:

  1. Using YaST -> Network Devices -> Remote Administering -> Allow Remote Administration

  2. Firewall is disabled

  3. I have installed free RealVNC on Windows XP

Problem when I try to use RealVNC to connect to:

  • 192.168.XXX.XXX:5900 it gives me error "unable to connect to host: Connection refused (10061)"

  • 192.168.XXX.XXX:5901 gives me a black screen with mouse pointer

In browser is the same results with just different ports 5800 and 5801

What I have missed?

Updated:

Yes, it worked. What I have done is:

  1. Open Gnome Terminal
  2. Type command "vncserver"
  3. Enter client access password
  4. Open File Browser -> View -> Show hidden files
  5. Open ~home/.vnc folder
  6. Open xstartup file in gedit
  7. Replace existing code with next 2 lines:
#!/bin/sh
/usr/bin/gnome &

And it start working, thanks to Jed Daniels

share|improve this question
    
I am experiencing the same issue with the black screen - I changed from twm & to gnome & but still no luck –  JohnIdol Jun 19 '11 at 18:51

3 Answers 3

up vote 1 down vote accepted

It sounds like you probably are getting connected, but don't have any X desktop configured. Check out this page for instructions on configuring a different desktop manager (you can probably skip the sections about installation and go right to the section on Configuring).

share|improve this answer

Also you can configure various attributes of the VNC desktop by editing /etc/xinetd.d/vnc (You can have multiple VNC ports with different configs. You can change dimensions and color resolution, service port, the vnc server binary (you can use a traditional X server instead of Gnome/KDE desktop with background and taskbar etc.))

share|improve this answer

you must change X example for LXDE

#!/bin/sh
/usr/bin/lxsession &
share|improve this answer
3  
Can you contribute more or explain how this is different from the already accepted answer? –  Brent Pabst Nov 20 '12 at 15:42

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.