Server Fault is a question and answer site for system and network administrators. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top
USE GlobalSales;

EXEC sp_helpmergepublication GlobalSales
EXEC sp_helppublication GlobalSales
EXEC sp_helppublication_snapshot GlobalSales

-- Execute this batch at the Publisher.
DECLARE @publication AS sysname;
DECLARE @subscriptionDB AS sysname;
DECLARE @subscriber AS sysname;
SET @publication = N'Mitjab-Notebook\SQL2008'; 
SET @subscriptionDB = N'GlobalSales'; 
SET @subscriber = N'SERVER\SQL2008';

-- At the Publisher, register the subscription, using the defaults.
USE [GlobalSales]
EXEC sp_addsubscription 
    @publication = @publication, 
    @subscriber = @subscriber, 
    @destination_db = @subscriptionDB, 
    @subscription_type = N'pull', 
    @update_mode = N'failover';

but i get:

Msg 14013, Level 16, State 1, Procedure sp_MSrepl_helppublication_snapshot, Line 29 This database is not enabled for publication.

share|improve this question
up vote 1 down vote accepted

You can't do replication (as publisher) with the Express Edition

share|improve this answer

So then enable publication, or run this on the database which is enabled for publication. Take a look in the replication options to configure publication and distribution.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.