Server Fault is a question and answer site for system and network administrators. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have a linux server, with postfix just installed.

I am new to email-servers...

Anyways, I am able to send mail with php:s mail function, but they are considered "spam" by google mail (and probably most other email accounts also, haven't tested hotmail, yahoo etc).

I am guessing it has something to do with SPF, but I don't have a clue what SPF is, how to fix it etc etc...

Can anybody explain how to make my emails "Non-spam" which they are not?

OS is Ubuntu 9.10.

If you need more input let me know...

Thanks

PS: How can I disable all incoming mail to my postfix (email server) without using my firewall, maybe by using main.cf?

share

merged by Kyle Brandt Jul 5 '10 at 20:38

This question was merged with Got postfix and mail working, but the emails are considered “spam”, why? because it is an exact duplicate of that question.

migrated from stackoverflow.com Jul 5 '10 at 19:16

This question came from our site for professional and enthusiast programmers.