Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I'm seeing this error when I run python2.6 setup.py build on Debian Lenny from the setuptools-0.6c11 source:

Compression requires the (missing) zlib module
share|improve this question
add comment

1 Answer

up vote 1 down vote accepted

I think the problem is that python2.6 was not build with zlib. I ran the following commands and this fixed my problem (this assumes you have the Python 2.6 source):

apt-get install zlib1g-dev
cd Python-2.6.5
./configure
make
make install

... there are also lots of other things that python will build with. The installer will not fail if they're missing, it'll just build without them.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.