Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

It's hard even to describe my problem.

It seems there's only problem with extreme slow openings (up to 10 minutes) on Windows 7 (on XP things works fine) for files that are stored on Windows Server 2008.

And now what I discovered up till now.

  1. If I open (some files, not all, not always) .doc and .xls files with double-clicking it takes up to 10 minutes to finally open the file. In that time, file seems to be locked for all other users. If I cancel opening, file remains locked for some time.

  2. Owner on that files is the one who last wrote changes in them. If I change the owner to larger group, which I am member of file gets opened super fast.

  3. When opened file can be saved normally and fast. That file reopens fast.

  4. One other user reports that there is only problem when opening the files for the first time in a day. When he opens first file he has no problems with other files at all (or so he says). He also states that when accessing files from home via VPN he has no such problems with files.

And now: anybody has a clue where to start looking? I suppose that is misconfiguration problem. But where? File system? Permissions? DFS? VMWare network config?

My setup is as follows: Physical server: HP Prolian ML350 G6 Virtual host: VMWare ESXi 4 Guest: Windows Server 2008 Standard Files are accessed via DFS shares.

share|improve this question
add comment

2 Answers 2

Look at the cache settings on the shared folder on the server and make sure caching is disabled.

share|improve this answer
add comment

We have had the same problem. Took us forever to figure it out. It was related to SMB2. Disable SMB2 on the server -

Add a REG_DWORD entry named Smb2 with a value of 0 to HKLM\System\CurrentControlSet\Services\LanmanServer\Parameters

Restart server and you should be ok.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.