Server Fault is a question and answer site for system and network administrators. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

The "www" prefix for my domain is not working, even after updating the DNS zone by adding www as a cname of, or adding www as a A record with the actual server IP address. As it is a dedicated server I even added the ServerAlias line on Apache, but still none of the solutions worked. Any ideas?

Additional information: on, the "www" section says:

WWW A Record     Your A record is: -> -> -> [ cname_error  ] 

[Looks like you have CNAME's]


share|improve this question
Problem fixed: it was actually an NS issue; the changes weren't applied then >< – Nicolas Jul 8 '10 at 10:08
up vote 3 down vote accepted

Not a lot of technical information about what you are doing or working with. However I would start with pinging the host. Is that working (forget about apache for the moment)?

If not then check how you entered the hostname, some configurations want just www and the ip address and some systems want the full

To me the error you got reads that you have a looping lookup. One CNAME pointing to another. Just have the www as an A record as a start.

share|improve this answer
I do agree with you an the looping, but I can't figure it out. I can ping the server, but not When you talk about the hostname, you mean on the DNS zone from the DNS provider? – Nicolas Jul 6 '10 at 12:03
+1, Start with just setting up a A record. – Chris S Jul 6 '10 at 12:42
Done, but I have to wait then. How do I know when this is working? Is there any website that read all the DNS information? – Nicolas Jul 6 '10 at 13:36

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.