Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I have two cisco switches and a cisco router. The router connects to the first switch (A) and the second switch (B) is connected to switch A. Switch A only has one vlan port set (The one that connects to switch B). From a device connected to switch B I can access anything that is connected to switch A. But from switch A I can not access devices that are connected to switch B. Devices connected to Switch A and B can access things behind the router just fine. What do I need to add to the router or switches to allow devices connected on switch A to access devices connected to switch B ... some of the configuration follows to give more detail.....

Switch A
Most ports are set as
interface FastEthernet0/2
no ip address
end

The Port that connects to Switch B is set as
interface FastEthernet0/20
switchport access vlan 5
no ip address
end

Switch A also has VLAN's Set

interface Vlan1
ip address 192.168.2.10 255.255.255.0
end

interface Vlan5
ip address 192.168.5.1 255.255.255.0
end

Switch B All ports are configured like the following
interface FastEthernet0/2
switchport access vlan 5
end

The Router uses the folling route
ip route 192.168.5.0 255.255.255.0 192.168.2.10
And has an IP address of 192.168.2.1 (Putting it in the same subnet as switch A)

The interface on the Router has the following config ...

interface FastEthernet0/0
ip address 192.168.2.1 255.255.255.0
no ip redirects
no ip unreachables
no ip proxy-arp
ip flow ingress
ip flow egress
ip nat inside
ip virtual-reassembly
no ip route-cache cef
ip route-cache flow
no ip mroute-cache
duplex auto
speed auto
no mop enabled
service-policy input LAN-EDGE
end

share|improve this question

1 Answer 1

up vote 0 down vote accepted

In this case it was something stupid ... I did not have a default gateway set on Switch B (Which has an IP address of 192.168.5.2) as soon as I set the ip default-gateway 192.168.5.1 everything worked great.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.