Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

CentOS 5.x | Apache 2

I'm setting up an instance of w2box on my web server. It basically uses a standard perl script (upload.cgi) to store a file being posted.

As a test, I'm trying to upload an ubuntu ISO (716 MB). However, when I examine the apache access logs I see this:

- [07/Jul/2010:03:08:44 +0400] "POST /upload.cgi?sid=a4984a5sdkfjhsdkfhsdk68ef1c25f5931&maxsize=1073741824 HTTP/1.1" 500 636

My PHP limits are:

post_max_size 1100M

memory_limit 1200M

My question though is, why is the maxsize so high in the POST url? Does the web browser do some extra encoding that bloats the size of data?

If I want to support uploads of up to 1 GB, what would my php memory values need to be?

-M

share|improve this question
add comment

1 Answer

up vote 1 down vote accepted

That "maxsize" parameter in the URL doesn't seem to be related to either PHP or Apache.

It's probably a value that your PHP application is expecting. If it's specified in bytes, it means 1024MB.

share|improve this answer
    
Thanks Guys. You're right. It was an additional parameter in the upload.cgi script. Thanks! –  Mike B Jul 6 '10 at 23:42
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.