Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I'm running WAMP on a Win7 virtual machine. I'm trying to access the server via my web browser, but it's not working.

Inside the VM, the IP address is shown to be 192.168.31.132

Going to http://192.168.31.132/ however, delivers a 403 Forbidden error.

I don't know what happened to cause this. I tried this right after installing the software, default settings all the way.

I turned off Windows Firewall on the VM, didn't change anything.

So I wonder, what setting in Apache is making this happen?

EDIT: things did work after I put the server online...

Question solved

share|improve this question
1  
did you check permissions of the www-data/htdocs folder? perhaps the user running Apache has no access to that folder, you can set the folder to everyone (read) as a quick test. –  Luma Jul 7 '10 at 5:36
    
That folder does not exist. I'm not running linux, I'm not working with a custom Apache install. I'm using WAMP, as stated in my post. –  KdgDev Jul 11 '10 at 21:41

1 Answer 1

up vote 1 down vote accepted

The problem, as Luma pointed out, are most likely the file permissions on www-data/htdocs. Try that first.

If that fails, enable verbose logging in Apache (LogLevel debug in the config, reload/restart Apache), then trigger the error and look into the logs to see what is going wrong.

If you 're still stuck, edit your question with this additional info, then maybe we can help.

share|improve this answer
    
I can't find any setting with the word "verbose" in it. –  KdgDev Jul 11 '10 at 21:44
    
@WebDevHobo: That were just my words. The setting to change is LogLevel, and the value is debug. See httpd.apache.org/docs/2.0/mod/core.html#loglevel –  sleske Jul 11 '10 at 22:43

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.