Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have a domain (.se) that I have "own" for years, I've been pointing out a dyndns domain as the nameserver for my .se domain to be able to use my top domain with a dynamic ip internet connection. This has been working for over 5 years, but now It has stopped working

The DNSCheck v1.0.1 response is this:

No name servers found at child. Superfluous name server listed at parent: A name server listed at the parent, but not at the child, was found. This is most likely an administrative error. You should update the parent to match the name servers at the child as soon as possible.

How do I resolve this?

Edit:

This is how it's setup:

domain.se NS domain.mine.nu

There is NO dns-server running on domain.mine.nu and have never been. And thats it, it has worked flawlessly for over 5 years, but now it has stoped, can anyone figure out why?

share|improve this question
    
I realize you're concerned about privacy, but you'll get a definitive answer rather than wild guessing if you just let us know what the domain is. –  Stephen Jennings Jul 8 '10 at 7:19
    
the domain is kuseman.se if that would help –  Marcus Jul 8 '10 at 8:08
add comment

4 Answers

This means that your nameservers (NS records) are not in the zone configured on your DNS server.

You should be able to do:

$ dig yourdomain.se NS @yourdnsmaster

and get NS records as a result.

share|improve this answer
    
I don't host a DNS-server and have never had, my .se domain have worked anyway "some how". –  Marcus Jul 7 '10 at 17:14
    
One other wierd thing is that I cannot access my domain.se but running a whois on it, that service can access my system, it tells me what server-os im running etc. –  Marcus Jul 7 '10 at 17:37
add comment

Try this:

dig se NS

Take one of those results, say a.ns.se, and do this:

dig @a.ns.se domain.se ns

This will give you the "parent" list of nameservers. Now, take one of those results (let's say foons), and do this:

dig @foons.domain.se domain.se ns

This will give you the "child" list of nameservers. You need to make these two lists equal by finding who is hosting your DNS (probably the site where you registered the domain) and fixing the problem there.

share|improve this answer
    
Hi, the first one gives my my dyndns nameserver, works! The second one time outs. I'm suspecting that I need to host my own nameserver (and thats why it's time out), but the thing is that I have never ran my own nameserver, it has worked anyway. –  Marcus Jul 7 '10 at 19:22
add comment

You need to look at the settings from your domain vendor (like Network Solutions or GoDaddy) that you purchased your domain from. There should be settings for DNS as part of your domain. Make sure that the DNS settings are pointing to dyndns DNS servers.

Follow the instructions here:

Custom DNS

HTH

Mike

share|improve this answer
    
The Custom DNS service would probably solve my issue, but the thing is that it have worked without it, why has it stoped working now? the nameserver for my .se-domain points at my dyndns-domain (NOT dyndns nameserver), and I don't host my own nameserver. –  Marcus Jul 8 '10 at 6:53
add comment

Usually this kind of error is the result of an NS record mismatch. For example, you have ns1/ns2.somedomain.com listed as the DNS servers with the registrar, but the actual DNS zone file lists ns1/ns2/ns3.otherdomain.net in the NS records. Updating the NS records in the DNS zone file at the DNS service provider to match what you're using at the registrar (or the other way around) will generally correct these kinds of problems.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.