Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.


I'm trying to set up a mail server for our dedicated server, and the only thing remaining that doesn't work is the POP login. The outlook dialog box just keep asking me for the right user name/password.
Here's the output from tailf -f /var/log/syslog:

Jul  8 11:06:48 newserverxxxx dovecot: pop3-login: Disconnected: rip=93.97.xxx.xxx, lip=94.76.xxx.xxx

Information:

  1. The User does exist, and I can log on
  2. All the other steps works (SMTP, and mail test)
  3. And I can even send mails to other addresses from the server or a mail() call

Cheers,
Nicolas.

share|improve this question
    
how do you have dovecot configured? Local users? Mysql backend? What port is dovecot listening on? Are you using any kind of encryption? –  d-_-b Jul 8 '10 at 16:56
add comment

2 Answers

up vote 0 down vote accepted

Seeing the pop3-login process in your logfile means it seems configured. So I suggest to enable authentication debugging:

grep -e 'auth_verbose' -e 'auth_debug' /etc/dovecot/dovecot.conf (set these two to "yes" and restart dovecot).

share|improve this answer
    
Thank you for your response. I configured the debug parameters, and here are the results: Jul 22 12:59:46 newserverxxxx dovecot: pop3-login: Login failed: Plaintext authentication disabled: rip=93.97.xxx.xxx, lip=94.76.xxx.xxx Jul 22 12:59:46 newserverxxxx dovecot: pop3-login: Disconnected: rip=93.97.xxx.xxx, lip=94.76.xxx.xxx Jul 22 12:59:46 newserverxxxx dovecot: auth(default): new auth connection: pid=25600 It looks like the plain text login authentication is disabled, but when I check dovecot.conf, the disabling line is commented and the plain is authorised in the default settings –  Nicolas Jul 22 '10 at 12:08
    
So, I tried to uncomment the line : disable_plaintext_auth = yes, and then turned it into: disable_plaintext_auth = no. and IT WORKS! Thank you for the verbose suggestion. Nicolas. –  Nicolas Jul 22 '10 at 12:15
add comment

Try the full email address as the user name (johnsmith@example.com or johnsmith+example.com)

Hosted servers often require the entire email address to distinguish between the same user name on multiple domains. You may have configured POP to require disambiguation.

share|improve this answer
    
Thank you for your answer but it doesn't work neither. –  Nicolas Jul 8 '10 at 15:13
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.