Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

Hey, I changed my web application to use my computer name instead of the IP. Since then, the DNS lookup is very slow for 1 out of 3 pages (takes 3 seconds average). Right now, I use the default system settings for proxies. This happens in all browsers.

Here's what it looks like in Firebug.

alt text

How can I fix this? Also, what changes should be made for using computer names for all my network also not just this PC I'm using? I'm using Windows 7 64-bit. Thanks.

Edit: Here's my hosts file:

 127.0.0.1       localhost
 alex-pc         localhost
share|improve this question

1 Answer 1

up vote 1 down vote accepted

Local host file should look like this:

127.0.0.1      localhost
127.0.0.1      alex-pc

To have other PCs connect to alex-pc you need to add a DNS A record on your router (if it supports it) to point to your PCs local LAN address. Or add alex-pc into all your PCs hosts file. If your router does not support it. Setup a small DNS server on a computer and point all your PCs to that computer for DNS queries. Or change the DNS server in your DHCP settings and release/renew your other PCs. There is not enough details in your question to give more a more accurate fix.

share|improve this answer
    
That did the trick. Thanks. –  Alex Demers Jul 9 '10 at 2:25

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.