Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

Is it possible to start a VNC server in Ubuntu in display 0 without using default VNC server Vino?

My intention is I don't want the notification in the machine running VNC server when one client is connected to the server.

share|improve this question

5 Answers 5

up vote 1 down vote accepted

I think you should be able to do this with tightvnc.

sudo apt-get install tightvncserver

sudo apt-get install xtightvncviewer

You have to start the server process in a shell (typically ssh) before you can connect with a client. You can also use any vnc client to connect, for instance I use a windows vnc client for this.

share|improve this answer
    
hi .. but i can't setup vncserver in display 0 suresh@suresh-desktop:/media/backup$ tightvncserver :0 Warning: suresh-desktop:0 is taken because of /tmp/.X0-lock Remove this file if there is no X server suresh-desktop:0 A VNC server is already running as :0 but no vino or vnc processes are running in background –  suresh May 30 '09 at 18:52

If you really want the VNC server on display 0, and you don't want to use x11vnc or something similar to mirror another X server, you're going to have to shut down the X server that's running on display 0 (probably launched by gdm), or configure it to run on another display.

share|improve this answer

Rfb will export the current display without needing to restart X etc. (It seems only krfb is available in recent ubuntus, so you'll need to install all sorts of kde libs - I guess the vanilla rfb isnt actively developed, shame.)

share|improve this answer

I use x11vnc, for similar result: ssh remotehost ( export DISPLAY=:0; x11vnc -shared -forever -usepw -ncache 10)

you get the idea. hope it help.

share|improve this answer

If the intent is not to receive notification, you can turn it off in vino. Go to System->Preferences->Remote Desktop. Choose the settings to turn it off. In the Advanced tab, there is an option to turn off the notification icons as well.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.