Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I added a user to a group and set the file and dir content to 775. When i use winscp to modify a file it complains it cant set the timestamp bc of a permission error. But it is able to update the file i edit. Why? details on how i set the user is here but i dont think anyone needs to read it http://serverfault.com/questions/159179/why-cant-a-group-member-modify-a-file-in-a-group-he-is-part-of

share|improve this question
    
What are the permissions and ownership on the directory the file is in? –  chicks Jun 12 at 11:07

2 Answers 2

I guess your directory has the wrong owner/group, though the file itself has. What WinSCP is probably complaining about is that it can't set the directory’s timestamp, which is normally also updated if you change a file in it.

share|improve this answer
1  
I am logged in as root. Its tryint to set the time to the past to match the file on my FS rather then upload time. –  acidzombie24 Jul 17 '10 at 13:52

WinSCP tries to 'preserve time stamp' by default. Some unix systems do not like letting users that don't own a file to change permissions or timestamps even if they have write access, for some strange reason.

To fix this error I went to WinSCP Options > Preferences > Transfer then edited the Default and unchecked Preserve timestamp.

This, I believe, leaves you with the functionality that when a file is modified the timestamp is updated, which makes sense I guess.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.