Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I'm routinely having issues with the Terminal Server not accepted mstsc connections intermittently, especially on the weekends. I set the Services for Terminal Server to restart service on failure, even after 3rd attempt. What can I do to prevent this happening? Also, can I setup another method to access the server? Because right now I can't access the server to fix it.

Thanks

share|improve this question

1 Answer 1

This may sound basic, but the network card slept to sleep? That would explain the weekend issues.

You'll find that in Computer Management, Device Manager, right click the network card and go to advanced settings.

Also, does the firewall in front of the server have access rules that are based by hour/day? Most decent firewalls have settings that can be config'd as such.

To test both of these, you can simply open cmd and telnet the ip over 3389 (the default RDP port), if you get a blank screen or a response then it's not the firewall or network connectivity but a config issue.

telnet ip/dnsOfServer 3389

You can also setup VNC http://www.realvnc.com/ to replace RDP if needed.

share|improve this answer
    
I checked the server today and the NICs were set to sleep. Thanks. I wish all the problems were this easy. –  user46992 Jul 12 '10 at 21:42
    
cool, go ahead and accept my answer =) –  Malnizzle Jul 13 '10 at 15:12

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.