Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

We have a really strange problem here with the printers in our company. We have several users travelling often from Europe to the US and back. Their laptops are set up in the US. So all their configuration regarding the paper size is "letter". But when the users are in Europe they have only printers with A4. Since they are less then 10 users we decided to install their "Europe" drivers directly on the laptops and not distribute it over Active Directory.

Now to the problem: Our Xerox printer will not print MS Excel documents. The test page and print outs from IE or MS Word are fine. (For MS Word we needed to set a special parameter in order to change the size of the document automatically. But this feature is not available in the printer dialogue of Excel. We already tried to set the paper size of the Excel document to A4.

According to the manufacturer the printer should have a feature to automatically expand letter pages to A4. When we asked a Xerox technician why this is not working in this case then he replied that Excel is sending wrong information. It declares the document as A4 but is sending all the data (measurements) regarding the size letter.

Somehow I can not believe this. Did someone else have the same problem? The only "solution" I see is to print Excel documents first into PDF documents and then print those on the printer. But this is not really an acceptable solution.

Did anybody have a similar problem and found some "hidden" configuration parameter within Excel that could help me?

All laptops have Windows 7 and Office 2007.

share|improve this question
add comment

5 Answers

I have xerox workstation 7125 so this may apply to you. We had a problem that excel documents would insist to print letter format (for example if they are just created from .cvs format). There are two things you can check:

  1. Large xerox printers have in configuration setup to "use close matching size" - this would scale letter up to a4
  2. In excel options (office 2010) there is setting to "scale documents" that is default "on-checked", if that option is checked off excel do not scale documents and magically choose to use default drivers format.

Hope that these two hints help.

share|improve this answer
    
We had the problem back then with Office 2007. But thank you for the answer. It will help for sure those who have Office 2010. –  Raffael Luthiger Mar 17 '13 at 17:53
add comment

I have come across a similar problem with Xerox MFPs and Excel before. In Excel, go to Page Setup, make sure that the Page Size is correct and the Print Quality is set to 300dpi or 600dpi. For management, you can make a macro to set the DPI and then print. Add the macro to the Quick Access Toolbar.

share|improve this answer
    
Interesting. I will try this. Do you know exactly what the problem is? The print quality is definitely something I did not check before. Maybe this helps. I will let you know. –  Raffael Luthiger Jul 12 '10 at 21:04
    
Sadly this did not work for me. We asked now for a technician from Xerox. I hope that they can help us. –  Raffael Luthiger Jul 13 '10 at 17:59
add comment

I did have the same problem on Xerox 4250. Printing in PDF or with Word 2007 worked but with excel 2007 it didn't. I tried to change parameter in excel, format and other things without success.

I solved it with this (it was in french so I'm trying a translation of the parameters) : In the driver settings -> support (the type of paper) -> Adapt to new size It was the default setting so "no adaptation" and I switched it to A4.

This solved the problem and now I can print whatever the format is in excel 2007.

I changed also a parameter in the printer first to auto-scale 8.5*11 to A4 or reverse but it didn't solve the problem.

share|improve this answer
add comment

One of my customer is an Italian subsidiary of an US company. They have no problem with autoresize function of HP laserjet and dey use Excel A LOT.

You could try to print a PDF from Excel (using maybe PdfCreator http://sourceforge.net/projects/pdfcreator/) and see if the problem persists.

share|improve this answer
    
I already tried this and it does work. But since those users are on senior management level they want to have an easier solution. In other words they just want to press the print button. Let's see if someone else comes up with another solution. –  Raffael Luthiger Jul 11 '10 at 21:58
    
Can you try with an HP LaserJet with Letter-A4 automatic conversion activated? –  lrosa Jul 12 '10 at 5:26
    
Sadly there is no HP printer in this office. I will try first what torai suggested. Maybe this will help. Else I will have to search for one. –  Raffael Luthiger Jul 12 '10 at 21:03
add comment

I had the exact same problem Raffael

The solution for me was :

  1. Excel Options->Advanced->(Scroll down to) General
  2. Untick "Scale content for A4 or 8.5x11" paper sizes".

I guess the scaling mixes up the formats and sends the wrong one to the printer. I hope it's not to late :)

share|improve this answer
    
The problem existed 3 years ago. So it is too late. :) But your answer might help others. We don't have the printer any more. –  Raffael Luthiger Mar 27 at 9:31
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.