Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

To get the additional features of dashboard in TFS 2010, we installed SharePoint Server 2007 with Service Pack 2 on the apptier of our TFS setup. After configuring it, we are not able to see the additional dashboards. What needs to be done to enable additional dashboard.

Site Action->Site Setting->Site Features->Agile Dashboards with Excel Reporting->Activate does not give any result and do not throw any error.

Thanks Upfront.

share|improve this question
add comment

3 Answers

up vote 1 down vote accepted

Central Administration > Operations > Enable Features on existing sites after going to this place , check Enable Features . Click Ok.

Then go to- Site Action > Site Settings > Site Features > Click Activate Agile Dashboard with excel reporting.

You will see all the Dashboard list like Bug, Build, Test etc on the left side.

share|improve this answer
add comment

Have you installed "Team Foundation Server Extensions for Windows SharePoint Services"?

In essence TFS needs to know about SharePoint and SharePoint needs to know about TFS.

See the installation/upgrade manual for details: http://www.microsoft.com/downloads/details.aspx?displaylang=en&FamilyID=2d531219-2c39-4c69-88ef-f5ae6ac18c9f

share|improve this answer
    
Hi Richard, thanks for reply. We have installed TFS2010 and SharePoint Server 2007 on same server. So it seems it is not required in this case. Could you please provide me any other alternative. –  Kabir Rao Jul 12 '10 at 7:56
    
@Kabir: You still need to follow the following sections in the install/upgrade guide to configure things. Please confirm you have done this first. –  Richard Jul 13 '10 at 6:44
    
I have done all the settings and configurations... –  Kabir Rao Jul 13 '10 at 11:44
add comment

@Kabir Please check and confirm that your Sharepoint is Enterprise edition and not standard. If Agile dashboard and agile dashboard with Basic reporting can be enabled easily and only problem is with excel reporting than Probably this is the cause. You would need to install sharepoint Enterprise

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.