Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have an Apache server running on Ubuntu server 10, using Passenger for Ruby on Rails. I have configured my site under the sites-enabled directory of Apache and can hit the server with an internal IP address (192.168.X.X) and the site comes back as expected. However, whenever I try to hit the site externally, either through the domain name or the IP address tied to the domain name, the site will not come back. I have a router in the middle with a static IP address, with Port Forwarding turned on (forwarding 80/443) to the server and I'm quite confident the issue isn't there. In fact, I even DMZed to the Ubuntu Server just to make sure. Also, all router firewall options have been turned off. So here is the question...

Is there something else I have to do with Ubuntu server to allow externally requested port 80 traffic? Otherwise, is there some settings that need to be set in Apache to allow domain or external IP address port 80 traffic through?

I'm pretty new to Apache, so, please take it a bit easy on me :-)

share|improve this question

migrated from superuser.com Jul 12 '10 at 7:01

This question came from our site for computer enthusiasts and power users.

    
possible duplicate of [Home server router problem ](superuser.com/questions/158279/home-server-router-problem) –  Ignacio Vazquez-Abrams Jul 9 '10 at 21:28
    
I think his situation may is based more around DDNS and router configuration, and less about server setup. Thank you. –  Jessy Houle Jul 9 '10 at 22:34
    
I think his situation may is based more around DDNS and router configuration, and less about server setup. Thank you. –  Jessy Houle Jul 9 '10 at 22:54
    
Can you provide your apache config also the output of ifconfig –  proy Jul 10 '10 at 20:20
2  
If your question is really that distinct @jessyhoule, than you should edit some additional information into you question as to what makes yours different and why the other answers didn't help. –  Ivo Flipse Jul 11 '10 at 9:56

2 Answers 2

check the config files under /etc/httpd/conf.d/ and make sure the Allow, Deny rules are permitting the external connection for the package you're trying to use.

share|improve this answer
up vote 0 down vote accepted

These settings worked. Taken from Passenger:

  <VirtualHost *:80>
  ServerName www.fippit.com
  DocumentRoot /var/www/fippit/public    # <-- be sure to point to 'public'!
  <Directory /var/www/fippit/public>
     AllowOverride all                   # <-- relax Apache security settings
     Options -MultiViews                 # <-- MultiViews must be turned off
  </Directory>

From the networking side here are the other changes I made:

/etc/network/interfaces

auto eth0
iface eth0 inet static
address 192.168.1.7     # <-- my internal static IP address
netmask 255.255.255.0
network 192.168.1.0
broadcast 192.168.1.255
gateway 192.168.1.2     # <-- my router IP address (port forwards 80)

/etc/hosts

192.168.1.7 fippit.com www.fippit.com
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.