Server Fault is a question and answer site for system and network administrators. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

My application is using apache and the server is integrated with siteminder. I am using suse 10, when I run cat command I am getting the following error:

 cat: symbol lookup error: /opt/netegrity/siteminder/webagent/lib/ undefined symbol: pthread_once

Even after I run clear command am getting this error. Can you tell me what the reason could be?

share|improve this question

Here's the answer to your question:

If an executable that you run gives a symbol lookup error, it probably means that the linker is attempting to use a version of a shared library that doesn't have everything in it that it should. This probably means that it is not looking in the right places, although it could mean that something was incorrectly compiled for your system.

On linux, ldd(1) is used to show which libraries are being linked into an executable, /etc/ is used to specify where the linker looks for libraries, and ldconfig(8) is used to rebuild the cache to the more recent shared libraries. Furthermore if you look in these man pages, you will see mention of relevant environment variables.

However, presumably what you really want to know is how to fix it. In order to advise an approach, it would be useful to know something about the installation process of siteminder. Does it, for example, use a chroot environment or some other special environment creation startup?

share|improve this answer
i haven't istalled the siteminder, can you tell me how to know its environment – rajesh U Jul 13 '10 at 6:39

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.