Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have an Exchange 2007 box, that in order to update to SP2/SP3, in preparation for 2010, I had to manually remove the old Exchange 2003 active directory left overs. In doing so I suspect I broke the ability for the Public folders database to load correctly.

Now Exchange tells me:

Exchange is unable to mount the database that you specified. Specified database: POWERHOG\Public Folders\Public Folder Database; Error code: MapiExceptionCallFailed: Unable to mount database. (hr=0x80004005, ec=-550)

Now, I still have the .edb file, and nothing has changed in that file itself as far as I am aware. How can I get Exchange to load this file, or recover the data into a new public folder if necessary?

share|improve this question

2 Answers 2

up vote 1 down vote accepted

If the article Chris posted doesn't help, you may find the eseutil useful - it can be used to recover/check the state of a database: http://www.msexchange.org/tutorials/Exchange-ISINTEG-ESEUTIL.html

share|improve this answer
    
0x80004005 isn't a corrupted DB error, so I don't think eseutil will fix it. It might be worth a try however. Be sure to take a backup copy of the files before running this. –  Chris S Jul 12 '10 at 13:41

protected by Michael Hampton Sep 26 '13 at 5:53

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.